Subversion Repositories psp

Rev

Show changed files | Directory listing | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
2494 3094d 09h jim /trunk/pspsdk/src/user/ http://forums.ps2dev.org/viewtopic.php?p=88404#88404  
2493 3197d 01h jim /trunk/pspsdk/src/utility/ Change from "unsigned int"
http://forums.ps2dev.org/viewtopic.php?p=87515
 
2492 3245d 11h raphael /trunk/libpspvram/ Fixed makefile for non-*nix style shells  
2491 3271d 05h raphael /trunk/libpspvram/ Fixed some typos in the comments of vram.c  
2490 3271d 05h raphael /trunk/libpspvram/ Added libpspvram Readme and changed license of vram so it's now also free to use as long as credited  
2489 3271d 06h raphael /trunk/pspsdk/src/gu/ Fixed bug, when sceGuDrawBufferList overwrote pixel format and it wasn't reset back, causing major graphical glitches  
2488 3286d 06h jim /trunk/pspsdk/ update README URL  
2487 3306d 10h jim /trunk/pspsdk/src/debug/ pspDebugScreenSetMaxX/Y from http://forums.ps2dev.org/viewtopic.php?p=85666#85666  
2486 3317d 20h jim /trunk/psplibraries/scripts/ Cleanup:
Instead of using " || { exit 1; }" after every line, just "set -e" so
the shell exits on error.
 
2485 3317d 21h jim /trunk/libvorbis/ Buggy configure.in is missing LIBS when testing for Ogg  
2484 3317d 21h jim /trunk/psptoolchain/scripts/ Cleanup:
Instead of using " || { exit 1; }" after every line, just "set -e" so
the shell exits on error.
 
2483 3317d 21h jim /trunk/ When running configure scripts, using:

LDFLAGS="-L$(psp-config --pspsdk-path)/lib -lc -lpspuser" ./configure ...

is incorrect. It needs to be:

LDFLAGS="-L$(psp-config --pspsdk-path)/lib" LIBS="-lc -lpspuser" ./configure ...

Make this change in the README files and in the psplibraries scripts.
 
2482 3317d 21h jim /trunk/freetype/builds/unix/ Forgot the psp additions to config.sub, oops  
2481 3317d 21h jim /trunk/freetype/builds/unix/ Update config.sub, install-sh, and config.guess from latest libtool.
Old versions of libtool would re-copy config.guess with "libtoolize --copy",
but new versions need "libtoolize --copy --install". Instead of trying to
detect the version, we'll just add config.guess to the repository for now.
 
2480 3318d 04h jim /trunk/pspsdk/src/libc/ Undo last commit -- it was bogus  
2479 3318d 04h jim /trunk/psptoolchain/ Remove temporary gcc workaround  
2478 3318d 04h jim /trunk/psptoolchain/ Undo the last changes to this file, they were bogus  
2477 3318d 06h jim /trunk/psptoolchain/ Fix buffer overflow in psp-ar, as detected by GCC's Fortify Source feature  
2476 3318d 06h jim /trunk/psptoolchain/ Update list of required packages  
2475 3318d 06h jim /trunk/pspsdk/src/libc/ Clarify argument type, required for new gcc  

Show All